This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: cygwin 1.7.13-1: can't execute shell scripts on samba share

On Apr 23 13:02, Michel Bardiaux wrote:
> [snip]
> > lgiambro@lorien ~
> > $ cat
> > #!/bin/sh
> > echo it works
> And man sh states " --norc Do  not  read  and  execute the personal
> initialization file ~/.bashrc if the
>               shell is interactive.  This option is on by default if the
> shell  is  invoked
>               as sh."
> Which eliminates bashrc as a possible culprit.
> I have also tried the same as you did ( on a samba share) and saw
> the same problem. Then I saw that the got a (cygwin *and* linux)
> mode of -rwxrw-r-- *without* doing any chmod. Then I saw that *every*
> file I create on the samba share, gets the same mode!
> First things first, is there a workaround? Yes, chmod 777 *done
> on linux* works. And it actually works too when done on cygwin.
> However, recreating on cygwin, then a chmod 700 again on
> cygwin, does not work, again "./ Permission denied". But the mode
> seen on the linux side is -rwx------.
> I have also tried deleting then recreating the file in cygwin, then
> closing all cygwin processes and unmapping and remapping the samba
> drive. No cigar.
> Then I tried cacls in various situations. It turns out that with mode
> 777, cacls reveals "Everyone:F", but with mode 700 we get:
> <Account Domain not found>F
>               <Account Domain not found>(special access:)
>               Everyone:(special access:)
> And getfacl says:
> # file:
> # owner: ????????
> # group: ????????

You could mount the samba share with "noacl", see


Corinna Vinschen                  Please, send mails regarding Cygwin to
Cygwin Project Co-Leader          cygwin AT cygwin DOT com
Red Hat

Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]