This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Openssh stops working after a few days (problem solved)

On Sat, Dec 8, 2012 at 10:07 PM, Mike Richardson <> wrote:
> I was about to post this as a question on here, but I was able to
> solve my problem. I post it here in case anyone else comes along and
> has the same problem.
> I'm running Windows Server 2008 R2 Enterprise.  I installed the latest
> Cygwin/openssh package from scratch and everything runs fine for a few
> days.
> Then all of a sudden, I can't make any more connections to the ssh
> server.  My first step is to restart the service in Windows, but I
> receieve the following error:
> "The CYGWIN sshd service on Local computer started and then stopped.
> Some services stop automatically if they are not in use by other
> services or programs."
> I then examined the file /var/log/sshd.log and saw the following error message:
> "Privilege separation user sshd does not exist"
> I then examine the sshd account on Windows (which does exist). The
> "Account is diabled" box was checked. I uncheck it, as well as check
> the "Password never expires" checkbox which was before unchecked.
> After I click ok, I get the following error message:
> "The following error occured while attempting to save properties for
> user sshd: The password does not meet the password policy
> requirements.  Check the minimum password length, password complexity,
> and password history requirements".
> Next, I assign the windows account sshd a sufficiently complex
> password using the windows gui.
> Then I still get the same error "Privilege separation user sshd does not exist"
> So I run the following commands:
> mkpasswd -l > /etc/passwd
> mkgroup -l > /etc/group
> I then restart the windows service, and now everything works fine.
> What I assume what happened is that the sshd account in windows
> somehow became disabled.

The ssd user is supposed to be disabled otherwise people can login as that user.

Robert Pendell
A perfect world is one of chaos.

Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]