This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

python2.6 appears to be missing _md5 module?

Hi cygwin developers,

Today I went to install the mercurial package, which depended on
python. It installed version 2.6.8-2 of python, but when I tried to
run "hg clone" it failed with a message "abort: no module named
_md5!". And indeed, if I simply started up python and tried things
like "import md5", "from hashlib import md5" or "import _md5" they all
fail with the same import error "No module named _md5".

If I install python 2.7.3-1, then the md5 issue goes away. That is, I
can import md5 in any of the ways I mention above (well, except as
"import _md5", but "import md5; m = md5.md5(); m.update('a');
m.hexdigest()" is functional.)

However, mercurial still fails. It appears to have hard-coded
references to the python2.6 versions.  (In /usr/bin/hg, it sets libdir
to "../lib/python2.6/site-packages"), and when I run "hg clone"; it fails with:

Fatal Python error: Interpreter not initialized (version mismatch?)
Aborted (core dumped)

Also, cygwin's setup now recommends that I "upgrade" my 2.7 back to
2.6, which works, but just returns me to the problem of a missing
_md5.  (It does have a and, but no _md5.*)

Anything else I can try or report?

I am on a Win7-64bit system, using cygwin DLL version 1.7.17-1.

Thanks for any help!


Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]