This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: trouble accessing samba shares with spaces and/or parentheses

On 12/21/2012 06:19 PM, Corinna Vinschen wrote:
On Dec 21 18:01, bartels wrote:
On 12/21/2012 05:47 PM, Corinna Vinschen wrote:
On Dec 21 17:20, bartels wrote:
$ net use Q: "$(cygpath -w '//macau/X32 Backup-4(WD)')" "bartels" /user:"bartels"
The command completed successfully.

$ ls q:/
ls: cannot access q:/: Input/output error
Please don't use DOS paths.  Use POSIX paths like /cygdrive/q instead:
Naturally, I tried all flavours:

$ ls /cygdrive/q/
ls: cannot access /cygdrive/q/: Input/output error

Works fine for me using a Linux Samba share with space in it.
Okay, that leaves the parentheses as the likely troublemaker.
The thing is, people bring in disks, and I have no control over their volume / share names.

Any more ideas? Where's Santa when you need him ;-)
"Input/output error" is just an EIO.  strace might show more useful
information.  EIO could be generated for a couple of reasons, for
instance, the WIn32 errors ERROR_DISK_CORRUPT or ERROR_OPEN_FAILED are
translated to the POSIX EIO.  Another chance to get EIO is if something
goes badly wrong trying to read a symlink.  Or, that's always a chance,
the OSX smb server doesn't support some system call used by Cygwin.  It
wouldn't be the first such FS.

You must be Santa!

I did not believe it, but I tried the same share names on a linux server: that works fine.

Indeed it looks like a cygwin/mac problem.
That still leaves me with a lot of unhappy users.

So where can I find strace?

- bartels

Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]