This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Xmgrace now crashes with SIGSYS on launch due to recent update


Since a recent update, launching xmgrace now fails with a SIGSYS, even
on a fresh Cygwin installation. I believe the cause is an update to
libXmHTML0, of which the current version is 1.1.7-12. When I roll
libXmHTML0 back to 1.1.7-11, xmgrace starts and works fine.


Today I freshly installed Cygwin on a new Windows 8 x86 system on
which it has never been installed before. I installed a number of
packages that I need, including Grace (since I use xmgrace). Once
setup completed, I ran XWin Server, and in the xterm that opens I ran
xmgrace, like I always have done in the past on other machines. The

Warning: XmManager ClassInitialize: XmeTraitSet failed

Oops! Got SIGSYS

Please use "Help/Comments" to report the bug.
NB. This version of Grace was compiled with LessTif.
    Make sure to read the FAQ carefully prior to
    reporting the bug, ESPECIALLY is the problem might
    be related to the graphical interface.
Aborted (core dumped)

I tried a rebaseall, but that didn't solve the problem.

I went over to another machine (Windows 7 x64), where I had an
existing and working Cygwin installation and where I used xmgrace a
lot. I ran Cygwin setup on that machine to do an update, and let it
update approx. 150 packages. After the update completed, I ran Xwin
Server, and in the xterm I ran xmgrace. In the past this worked, but
this time it gave an error identical to the one above.

I went digging through the list of packages that were updated today to
try and identify which one may be causing the problem. I noticed that
libXm4-2.3.4-1 was freshly installed today, and I had no libXm4
packages before. In fact I had no packages under X11/motif before
today. So I went looking at the dependencies, and noticed that while a
decent number of packages use libXm4, I have almost none of those
installed. libXmHTML0 stood out to me, as it's a direct dependency of
Grace. This gave me the idea to roll libXmHTML0 back to 1.1.7-11. It
looks to me that 1.1.7-11 depends on libXm2 and not on libXm4. The
roll back to 1.1.7-11 solved the problem with xmgrace.

Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]