This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

cygwin install failed, need help troubleshooting

Short version:

Cygwin stopped working on my laptop for unknown reason, so I deleted
it and attempted to reinstall. Re-installation of cygwin failed for
unclear reasons. Please Help!

Long version:

I've had cygwin on my company laptop (32 bit WinXP Pro SP3) for about
2-years and it just recently stopped working ... I fear some kind of
policy update pushed out by company administrators broke something but
I don't know how to figure out what exactly happened. The powers that
be don't support cygwin on company machines, so I can't get any help
from them.

I ran setup.exe to re-install cygwin and that failed. I deleted the
entire installation of cygwin then re-ran setup.exe to make a clean
install ... still failed.

Every package seems to have exited with same or similar error message,
starting with this:

"2013/04/30 16:03:45 running: C:\cygwin\bin\bash.exe --norc
--noprofile "/etc/postinstall/"
     10 [main] mount (5944) C:\cygwin\bin\mount.exe: *** fatal error -
cygheap base mismatch detected - 0x771940/0x6E1940.
This problem is probably due to using incompatible versions of the cygwin DLL."

I googled that message about base mismash and all the evidence points
to cygwin1.dll being the issue but there's nothing useful about fixing
it. The only instance of that dll on this machine is the one
downloaded and installed by the setup.exe program, so it doesn't make
sense to think it's a bad version.

This was a fresh install so it appears to me that cygwin1.dll is not
getting installed properly by the installation script ... it's
apparently not getting loaded into Windows and since everything
depends on that one dll, nothing works. There is no mention of that
dll in the setup logs (full or standard) although I know it is part of
the cygwin base package. The cygwin1.dll file is present in /bin ...
but nothing seems to work. Rebooted after install and still no joy.

Can anyone suggest some troubleshooting to help resolve this?  I feel
severely handicapped without cygwin working on my laptop :-(


Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]