This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Clean install, incomplete setup - no home dir, broken PATH

On a new Windows 8 Thinkpad (W530) I installed cygwin - just the
default install, no additional packages.  The install completed with a
postinstall script error pop-up:

Package: _autorebase\n autorebase.bat exit code 1

Everything else seemed to succeed.  On starting a mintty, I am started
in /usr/bin with a PATH that omits /usr/bin.  EG:

   user@BISTUP /usr/bin
   $ ls -l
   bash: ls: command not found

Also, the home dir for "user" is not created.

After adding /usr/bin to the path and creating a home dir, things seem
to function OK - no weird crashes or anything.  But all new shells
start from the same place (/usr/bin) with a broken path.

Web searches turned up one other report of an issue like this but no
resolution.  EG:
   * "cygwin no home directory", "cygwin autorebase exit 1"

In that post, Larry Hall suggested looking in /etc/postinstall for
scripts w/o a '.done' suffix - and indeed I see autorebase.bat as the
only one in there out of 14 others that is missing .done.  He then
suggested running it directly and/or re-running setup.exe to get them
processed.  So I tried both but neither resulted in a "working"

Running it directly appeared to run w/o error but it didn't fix my
cygwin installation:

   C:\installCygwinTmpSpace>cd C:\cygwin



I also tried running the rebaseall command in dash to be sure I didn't
miss any errors but that didn't turn up anything either - it seems to
run just fine and returned w/o error.

   C:\cygwin>type etc\postinstall\autorebase.bat
   @echo off
   rem Postinstall scripts are always started from the Cygwin root dir
   rem so we can just call dash from here
   path .\bin;%path%
   dash /bin/rebaseall -p

   $ /bin/rebaseall -p
   $ echo $?

Then I re-ran setup.exe (setup.exe -nNd -q -L -l <path>) but it still
had the same complaint about autorebase.bat returning an abnormal exit
code 1 and new mintty's still leave me in /usr/bin and w/ a broken
PATH env var.

I've tried uninstalling and reinstalling half a dozen times from
different mirrors.  But on this Windows 8 box the failure happens 100%
of the time.  I also have this problem on one "Server 2012" box but
not on another.

I've attached the setup.log and the setup.log.full from another clean
install along with the output from cygcheck -csv (as run from a mintty
w/ /usr/bin added to the PATH).

I did look at the setup log pretty closely but I didn't seen anything
suspicious except the autorebase error code message - and I've run out
of ideas on how to debug it - maybe there is some way to get setup.exe
to run it in a way that returns more diagnostic info?

Thanks for any time or info you can give me - I can't live w/o cygwin
on my windows boxes.

Attachment: setup.log
Description: Binary data

Attachment: setup.log.full
Description: Binary data

Attachment: cygcheck_csv.out
Description: Binary data

Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]