This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: mintty, xterm and rxvt freezes when displaying a binary stream

On Mon, May 13, 2013 at 10:45:17PM +0100, Andy Koppe wrote:
>On 13 May 2013 22:35, Adrian H wrote:
>> I inadvertently dumped a binary stream to the terminal and it froze
>> mintty.  When I tried to kill the process dumping the data, it
>> wouldn't die, even when using -9 switch.  When I used Process Explorer
>> to kill it, it died and mintty resumed working.
>> I narrowed the stream down to 370 'lines' by catting the file and
>> heading and tailing its output.  For some reason, I wasn't able to
>> narrow it down any further.
>> This issue doesn't occur within cmd running bash (bash is what is
>> running through mintty when this occurred).
>> I've also tested it with xterm and rxvt and they also froze the
>> terminal, so it appears to be something to do with the terminal
>> interpreter which may be shared across these three terminal
>> programmes.
>> I've tried to attached the compressed narrowed down stream for you
>> viewing pleasure, but this mailing list doesn't support it. If anyone
>> wants to debug this further, just tell me where to put the binary file
>> and you can do your thing.
>> Not sure what that stream is doing to the terminal to do that to the
>> process, but I don't think it should be doing that.
>> Any idea what's happening?

Or, even better:

This is a really hard problem to fix in Cygwin.  It probably requires
YA rewrite of the pty layer.


Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]