This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Bash sub-shell freezing in Midnight Commander

I'm relatively new to Cygwin and am using it to enhance portability of a
software package I help maintain.  To be sure that a bug I was hitting
in my compilation was in my software package I updated Cygwin last week
and since then I have found that the sub-shell started by Midnight
Commander is apparently freezing.

I normally set mc for 'Lynx type motion', disable the hint bar, and have
the command bar visible.  When mc starts a Bash prompt should appear in
the command bar but since the update it does not.  I've tried
downgrading mc but that did not help.  I have found that mc is
responsive until a directory change is called or an external command is
attempted from the command bar.  I have found via Windows Task Manager
that the 'bash.exe' process instantly jumps to 99% CPU usage.  Once that
process is killed mc functionality returns (I didn't test all functions)
although the command bar is dead and no external commands can be run.

I deleted all of mc's configuration from my Cygwin user's home directory
and that did not change any behavior, so I suspect a Bash issue.  I've
not tried downgrading Bash to the 3.x version, however.

I haven't found this mentioned anywhere else, so I'm asking here.

- Nate


"The optimist proclaims that we live in the best of all
possible worlds.  The pessimist fears this is true."

Ham radio, Linux, bikes, and more:

Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]