This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Bash sub-shell freezing in Midnight Commander

* On 2013 14 May 11:52 -0500, marco atzeri wrote:
> Hi Nate,
> set mc for 'Lynx type motion', disabled the hint bar,
> but I always see the $ of bar command.

Hi Marco.

Using Windows Explorer I deleted the .cache, .config, and .local
directories (only mc had anything stored there) and started mc.  Upon
start with no configuration changes the command bar is visible but the
bash subshell prompt is not displayed.

> To remove it I need explicetely to set it in the options-layout
> So you are setting something else, I assume.

I've even replaced my slightly modified ~.bashrc with the copy from
/etc/defaults/etc/skel/.bashrc and started mc again with no change from
the default configuration.  The Bash prompt is still not visible in mc
and still has the same freeze where killing the bash.exe process
restores basic mc functionality.
> Additional, have you tried CTRL-o for switching to sub-shell in full
> window ?

I just tried it and mc calls the shell and then the mintty window
freezes before the subshell is run.  Windows Task Manager shows
Bash.exe using 99% of CPU and killing that process gives a bash prompt
and a mintty error box.  Evidently mc has been killed as it is no longer
shown by the 'ps' command.  To this point I have not set any
configuration options in mc.

Does that help?

- Nate


"The optimist proclaims that we live in the best of all
possible worlds.  The pessimist fears this is true."

Ham radio, Linux, bikes, and more:

Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]