This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

call to system() leading to execve() failed. (process table is full?)

Hi list,

First, I have carefully read the FAQ and the Cygwin documentation. I
have also read what seemed to be related problems to the one I will
described below, but could not find a solution to it, so I ask for help

A software I use makes use of the system() library call. When this
software is ran from a Cygwin terminal, all works properly, a shell is
spawn in a new process and the requested program is executed as
expected. When instead I run it from a windows 'cmd' shell, I get a
error that the system (I suppose the Cygwin layer) reports as stated in
the object of this mail "execve() failed (process table is full?)".

I have copied the /bin/sh.exe beside the binary, I also added to
/cygwin/bin directory into the windows %path% variable but still meet
this same error message.

I can successfully run the sh.exe from windows I get the shell prompt,
so to me the problem does not seems to be a malfunctioning shell...(?)

I understand that Cygwin implements the system() library call upon
execve() system call, but do not understand what is missing for it to
work when ran from windows, in other words what make it think the
process table is full?

Thanks in advance for any help,

Denis Corbin.

Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]