This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: cygutils Postinstall Script Errors With Exit Code 128

On Tue, May 28, 2013 at 2:43 Paul.Nickerson wrote:
> I am attempting to install Cygwin, and am getting errors near the end of
> the process. I am using version 2.774 of setup.exe on Microsoft Windows
> Server 2003 R2 Datacenter x64 Edition Service Pack 2 and the default
> Cygwin packages. This is an Amazon AWS EC2 instance, and I am remote
> desktopping in. In the Cygwin Setup GUI, after it goes through the install
> procedure, I get a window titled Postinstall script errors, with the below
> output text:
> Package: base-cygwin
> exit code 128
> Package: terminfo
> exit code 128
> Package: bash
> exit code 128
> Package: coreutils
> exit code 128
> Package: _autorebase
>         autorebase.bat exit code -1073741819
> Package: base-files
> exit code 2816
> exit code 128
> Package: cygutils
> exit code 127
> Package: man
> exit code 128

I got the cygutils postinstall error also, caused by missing dependencies.

$ cat /etc/postinstall/
/usr/bin/update-mime-database /usr/share/mime

both scripts do not exist, and are no cygutils reqs.
please test against it.
test -f /usr/bin/update-desktop-database && /usr/bin/update-desktop-database
test -f /usr/bin/update-mime-database && /usr/bin/update-mime-database

> If I then open Cygwin Terminal using the Desktop shortcut, I get a window
> titled "-sh" and a prompt that says "-sh-4.1$". The command "ls" returns
> "-sh: ls: command not found", but echo works. I have tried re-running
> setup.exe, removing the cygwin directory, re-downloading the setup.exe,
> removing HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Cygwin from the registry,
> setting "Turn on DEP for essential Windows programs and services only" and
> rebooting, altering file and folder permissions, deleting the cache and
> using different mirrors, and using rdesktop in CentOS vs. mstsc.exe in
> Windows to remote desktop in, but none of this changes the behavior.
> I have an odd and possibly related behavior. If I open Command Prompt, run
> C:\cygwin\bin\bash.exe --norc --noprofile
> to get a "bash-4.1$" prompt, then in there run
> if [ "foo" = "foo" ]; then echo "Expression evaluated as true."; fi
> the bash prompt will exit back to command prompt, and %ERRORLEVEL% has
> been set to 128.
> Running that if statement in the window brought up by the Cygwin Terminal
> Desktop shortcut will sometimes make the window close, but not always. I
> have not explored how I might be triggering the Desktop shortcut to work
> or not work.
> I have attached setup.log and setup.log.full.
> When I run cygcheck -s -v -r > cygcheck.out, it hangs and does not exit.
> Checking Task Manager, I see that it's using ~45% CPU (I have 2 virtual
> cores). It does write some things out to cygcheck.out, which I have
> attached. When I run the command in Command Prompt without redirecting
> output to a file, I get a little more information before it hangs, which I
> have copied out of the command prompt and attached as
> cygcheck-no-redirect.out. I do not know why it's saying I have multiple
> cygwin1.dlls on my path. There is only C:\cygwin\bin\cygwin1.dll.
> Looking at cygcheck.out, I am running in a Terminal Service session, which
> makes sense as I am remote desktopped in. My problem might be related to
> FAQ #2.14 (
> ), but the DEP solution is not helping me. I tried running
> "C:\cygwin\bin>peflags --tsaware=true --tsaware *" in Command Prompt, but
> it did not change anything.

Reini Urban

Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]