This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Postinstall Script Errors With Exit Code 128

cygwin-owner at cygwin dot com wrote on 05/29/2013 12:28:30 PM:

> From: "Larry Hall (Cygwin)" <reply-to-list-only-lh at cygwin dot com>
> To: cygwin at cygwin dot com, 
> Date: 05/29/2013 12:29 PM
> Subject: Re: Postinstall Script Errors With Exit Code 128
> Sent by: cygwin-owner at cygwin dot com
> On 5/29/2013 12:04 PM, Paul.Nickerson wrote:
> <snip>
> > I tried each of your suggestions, and they did not help it install. I 
> > tried cygcheck again, and it did not run any better. Any other ideas? 
> > at a loss right now.
> This list has seen the occasional question about AWS and Cygwin in the 
> but AFAIK, no one active on the list is using AWS with Cygwin.  My best
> suggestion at this point is to consult the Amazon folks to get their
> input.  The fact that cygcheck doesn't run to completion really points 
> an issue outside of Cygwin proper, since cygcheck is a vanilla Windows
> program.
> -- 
> Larry

I tried removing cygwin1.dll from the bin directory and re-running 
cygcheck.exe, and it ran to completion. When I ran it, I got the below 
popup and error, and I have attached the produced output, created with "
C:\cygwin\bin>cygcheck -s -v -r -h > cygcheck.out 2>&1". I got the error 
after the Path: and before SysDir:.

id.exe - Unable To Locate Component
This application has failed to start because cygwin1.dll was not found. 
Re-installing the application may fix this problem. 

garbled output from 'id' command - no uid= found

Looking at cygcheck's source, it looks like after displaying "Warning: 
cygwin1.dll not found on your path" or "Warning: There are multiple 
cygwin1.dlls on your path", it runs dump_dodgy_apps() (which gives no 
output when I get cygcheck to run through to completion), and then it runs 
dump_sysinfo_services() (which gives the output "Can't find the cygrunsrv 
utility, skipping services check." when I get cygcheck to run to 
completion). So, I think that one of these functions hangs when 
cygwin1.dll is present. I'm thinking dump_dodgy_apps.

I tried copying cygcheck.exe to other directories and leaving cygwin1.dll 
in bin, and cygcheck does not hang when run from other directories.

 ~ Paul

Attachment: cygcheck-complete.out
Description: Binary data

Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]