This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Postinstall Script Errors With Exit Code 128

> From: "Larry Hall (Cygwin)" <reply-to-list-only-lh at cygwin dot com>
> To: cygwin at cygwin dot com, 
> Date: 05/29/2013 03:51 PM
> Subject: Re: Postinstall Script Errors With Exit Code 128
> Sent by: cygwin-owner at cygwin dot com
> On 5/29/2013 3:18 PM, Paul.Nickerson at desknetinc dot com wrote:
> > So, I think that one of these functions hangs when
> > cygwin1.dll is present. I'm thinking dump_dodgy_apps.
> Possibly.  You may have a BLODA problem (,
> whether known or unknown.  If so, getting rid of it will certainly help.
> > I tried copying cygcheck.exe to other directories and leaving 
> > in bin, and cygcheck does not hang when run from other directories.
> Interesting.  Maybe there's some Windows permission problems in the
> directory you were running from?

I have fixed it. Thank you for your help.

I have a few other AWS EC2 instances. One other was having trouble with 
Cygwin install, and none of the rest were. I tried comparing installed 
applications, but got nowhere. I also tried installing Windows updates on 
the troubled system, and copying the cygwin from a healthy system to the 
troubled one. Neither attempt worked. I had looked into folder permissions 
before, which all looked fine, and tried installing to another folder and 
even another drive, but that hadn't helped.

I then used WinDbg to run C:\cygwin\bin\bash.exe --norc --noprofile 
"/etc/postinstall/", and I think I got this 
error: SetContext failed, 0x8007001F. Looking online, it seems that code 
is associated with "A device attached to the system is not functioning". I 
have already rebooted a bunch of times. I used Belarc Advisor to grab the 
virtual hardware version. Belarc Advisor said the System Model / Main 
Circuit Board / BIOS on both troubled instances was "Xen HVM domU 
3.1.2-92.1.13.el5.", while on the other working instances it was "Xen HVM 
domU 3.4.3-2.6.18 09/01/2012".

So, I shut down the instance (I use EBS volumes), created an AMI from it, 
created an Instance from the AMI, and started up that instance. This has 
the effect of applying a new virtual hardware if available (proven by the 
fact that I get a new Instance ID), as well as moving to different 
physical hardware. After this, Belarc Advisor reported the good virtual 
hardware version. And, I was able to successfully install and use Cygwin 
normally. :)

I have attached the output of running that bash.exe command inside WinDbg, 
just in case it's useful for anything.

Again, thank you for you help.
 ~ Paul

Attachment: cygwin-bash-windbg.txt
Description: Text document

Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]