This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Problem with multiprocessing module from Python

Dear all,

Thanks a lot once more for the great software.

During my last attempt to build Sage on Cygwin (32), I mainly have
only one problem left: using the multiprocessing module from python is
I was using Cygwin 1.7.25 within a Windows XP virtual machine (VirtualBox 4.3).

This is true both with Cygwin's shipped Python 2.7.x and the one I
built for Sage.
Here is a small snippet of code reproducing the problem:
[Blah python stuff]
>>> from multiprocessing import Pool
>>> p = Pool(3)
>>> suitable)
ValueError: semaphore or lock released too many times
This might be a problem with Python but I seem to remember succeeding
in this test some time ago with the same version of Python.
I tried Cygwin's GCC (4.7.3) and a custom built FSF GCC 4.8.2 without success.
I also tried to replace Cygwin binaries with version 1.7.0 and a few
others before 1.7.25 without apparent changes.
So I'm a little lost now.

Can anyone reporduce that?
Any help would be appreciated!

I have another quite unrelated question while I'm here:
I recently had trouble because in Sage two DLLs ended up with the same
name and wanted to be loaded at the same time, resulting in a "cannot
reloacte blah.dll at the same address".
Renaming one of the dll (C file and rebuilding) solved the problem.
I assume this is a windows limitations, is that right?

Thanks in advance for your help,

Jean-Pierre Flori

Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]