This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Fwd: git clone fails on large repos when using cygcrypto-1.0.0.dll, works with 0.9.8

I've been having issues cloning large repos with git under Cygwin, but
only when I compiled git myself. The version of Git that Cygwin's
setup.exe downloads works fine, while mine would intermittently fail
with messages like this:

Cloning into 'testrepo'...
remote: Counting objects: 41107, done
remote: Finding sources: 100% (15143/15143)
remote: Total 149668 (delta 9296), reused 148822 (delta 9296)
Receiving objects: 100% (149668/149668), 613.20 MiB | 6.64 MiB/s, done.
fatal: pack is corrupted (SHA1 mismatch)
fatal: index-pack failed

Sometimes the clone would work, but not very often. Sometimes the
error wouldn't be SHA1 mismatch, but the result would still be cloning
failed. I found it odd that the binary from setup.exe worked, but my
compile of the same version would fail. I did a diff of the 'objdump
-x' from my compile and the binary from setup.exe, and the only
significant difference was my compile used cygcrypto-1.0.0.dll, and
the working version used cygcrypto-0.9.8.dll .

I tried simply replacing cygcrypto-1.0.0.dll with a copy of
cygcrypto-0.9.8.dll and my problems went away. It seems like there may
be some regression from 0.9.8 to 1.0.0 that is causing git to
intermittently fail.

Here is a link to someone else running into what appears to be the
same issue using the FFmpeg repo:

If anyone else is running into issues cloning with git on Cygwin (even
if the error is not the exact same message), could you try temporarily
replacing your cygcrypto-1.0.0.dll and check if this fixes your


Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]