This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: autoreconf: problem while executing

On 7/4/2015 5:30 PM, Simon Eigeldinger wrote:
Hi Marco,

Am 04.07.2015 um 09:58 schrieb Marco Atzeri:
On 7/4/2015 9:40 AM, Simon Eigeldinger wrote:
Hi all,

I still have the problem with autoreconf.
i executed rebaseall and had no luck.
i also tried reinstalling the whole cygwin environment. nothing.
all the packages are up to date.

When i execute autoreconf i get the following errors. anyone has some


$ autoreconf -i

       1 [main] perl 4304 child_info_fork::abort: unable to remap
Cwd.dll to same
  address as parent (0x780000) - try running rebaseall
Can't fork, trying again in 5 seconds at
  line 307.

please follow
Problem reports:

and attach a copy of cygcheck.out

attached is a cygcheck.out.
the system is as follows:
OS: Win XP servicepack 3 32 bit. haven't got a better system to test at
the moment, sorry.
Installed are all cygwin packages using the installer, just updated this
while the install i had some issues already while it was running
/etc/postinstall/zp_texlive_finish.dash and it hang doing this.
seems perl got stuck.
so the rebaseall script worked fine but it seemed to have some issues on
then i tried autoreconf and it showed me the errors above.

i also tunred off my antivirus software because i found out months ago
that it doesn't like cygwin all that much. so i had that turned off the
whole install and also when i use cygwin.
so it couldn't be the antivirus.

greetings and thanks for helping,

Hi Simon,
why have you installed everything ?

your system :
$ grep OK cygcheck.out |wc -l

my system:
$ cygcheck -cd |wc -l

so you have 4 time more packages then me and I am a heavy user.

I strongly suspect that you consumed all available
address slots for rebase, so the forks are almost impossible.
May be on a 64 system it will work, but on 32 bit you have an issue.

on my 32 bit system all the addresses from
 $ rebase -si | awk '{print $3}' |sort | head -n 1

to 0x6fff0000 are busy.

Please check the output of
   rebase -si | awk '{print $3}' |sort | head -n 1

or look for the lowest address using
 rebase -si |less

I suggest you to remove most of  not necessary programs.

Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]