This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Looking for 64-bit proxy

On 7/10/2015 3:16 AM, Kertz, Denis (D)** CTR ** wrote:
Marco Atzen wrote:

Hi Denis,
I uploaded on
can you test it ?

To install
setup-x86_64.exe -X -O -s -q -P connect-proxy

I installed and tested this on two different Win7 PCs and, unfortunately, neither one worked.

When I tried doing ssh login to a server via a proxy that works with the 32-bit connect-proxy, I got:

On the first PC tried:
     ssh_exchange_identification: Connection closed by remote host

On the second PC tried:
       1 [main] ssh 1092 child_info_fork::abort: C:\cygwin64\bin\cygiconv-2.dll: Loaded to different address: parent(0x460000) != child(0x2D0000)
fork failed: Resource temporarily unavailable

This seems a different issue.
Have you by chance the new BLODA "Lavasoft Web Companion" installed
on your PC ?

Can you also show the output of

 $ rebase -si |grep cygiconv

It should be something like :

base 0x0003c28b0000 size 0x00105000

When I did the install I did get this:
     Note:  Hand installation over to elevated child process.

I don't know if that means anything.  I did see from the /etc/setup install list that this is a single connect-proxy.exe executable.
It showed the same size on both PCs in /usr/bin so doesn't look like an install problem.

Is there anything else I can try, any debugging options/data?


Please follow
> Problem reports:

and attach the cygcheck.out


Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]