This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Xwin exits early

On 28/07/2015 16:43, Rainer Blome wrote:
For a few months now, the only way for me to get Cygwin/X to run
was to start a Cygwin terminal ("C:\cygwin\bin\mintty.exe -i /Cygwin-Terminal.ico -"),
then run "XWin -multiwindow -clipboard" from there, in the foreground.
That has worked for many weeks now.

I think this is saying that using the start menu shortcuts doesn't work, but I'm not sure.

Today, I upgraded from 1.17.1-5 to 1.17.2-1 (I think),
and XWin no longer starts as it used to.
No X icon appears, XWin exits almost immediately, with return code zero.

This is the output:
Welcome to the XWin X Server
Vendor: The Cygwin/X Project
OS: CYGWIN_NT-6.1-WOW ************ 2.1.0(0.287/5/3) 2015-07-14 21:26 i686
OS: Windows 7 Service Pack 1 [Windows NT 6.1 build 7601] (WoW64)
Package: version 1.17.2-1 built 2015-07-09

XWin was started with the following command line:

Xwin -multiwindow

(II) xorg.conf is not supported
(II) See for more information
LoadPreferences: /cygdrive/c/blome/.XWinrc not found
LoadPreferences: Loading /etc/X11/system.XWinrc
LoadPreferences: Done parsing the configuration file...
winDetectSupportedEngines - DirectDraw4 installed, allowing ShadowDDNL
winDetectSupportedEngines - Returning, supported engines 00000005

This is pretty odd.

* I tried leaving out all command-line args but "-multiwindow". Still no success.

How about leaving out all command-line args completely?

* I used the Cygwin installer to roll back to Still no success.

This tends to argue against that you were using 1.17.1-5 previously, or that other things e.g. the cygwin DLL were upgraded at the same time.

How can I troubleshoot this further?

Can you provide the logfile written by 'strace -o logfile XWin -multiwindow' which might shed some light.

Volunteer Cygwin/X X Server maintainer

Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]