This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Aw: Re: Xwin exits early

On 29/07/2015 18:49, Rainer Blome wrote:
Gesendet: Mittwoch, 29. Juli 2015 um 18:14 Uhr Von: "Jon TURNEY"
>I think this is saying that using the start menu shortcuts doesn't work,
>but I'm not sure.
Yes, a few months ago, they stopped working for me.
For my report this is "merely" context, although I would appreciate it if they worked.

On 28/07/2015 16:43, Rainer Blome wrote:
>>* I tried leaving out all command-line args but "-multiwindow". Still no success.
>How about leaving out all command-line args completely?
Same symptoms, exits after less than a second with same output (didn't diff, though).

>>* I used the Cygwin installer to roll back to Still no success.
>This tends to argue against that you were using 1.17.1-5 previously, or
>that other things e.g. the cygwin DLL were upgraded at the same time.
Yes, I may have come to 1.17.2 from a release earlier than 1.17.1-5

To be able to work, I installed VcXsrv which has "" in its version string.
That mostly works fine, except that it refuses connections from remote SSH-X-forwarding clients
(did not try to troubleshoot that yet, it's just been a few hours).

>>How can I troubleshoot this further?
>Can you provide the logfile written by 'strace -o logfile XWin -multiwindow' which might shed some light.
Yes, attached.

Thanks for this.


--- Process 7432 created
--- Process 7432 loaded C:\Windows\SysWOW64\ntdll.dll at 77D80000
--- Process 7432 unloaded DLL at 77A80000
--- Process 7432 unloaded DLL at 76920000
--- Process 7432 unloaded DLL at 77A80000
--- Process 7432 unloaded DLL at 77980000
--- Process 7432 loaded C:\Windows\SysWOW64\kernel32.dll at 76920000
--- Process 7432 loaded C:\Windows\SysWOW64\KernelBase.dll at 76AD0000
--- Process 7432 loaded C:\Windows\SysWOW64\sysfer.dll at 756C0000
--- Process 7432 loaded C:\ProgramData\Symantec\Symantec Endpoint Protection\12.1.4013.4013.105\Data\Definitions\BASHDefs\20150625.011\UMEngx86.dll at 6E5D0000
--- Process 7432 thread 8132 created
--- Process 7432, exception 80000001 at 756F69C1
--- Process 7432 thread 8132 exited with status 0x80000001
--- Process 7432 thread 8184 exited with status 0x80000001
--- Process 7432 thread 7692 exited with status 0x80000001
--- Process 7432 thread 7256 exited with status 0x80000001
--- Process 7432 exited with status 0x80000001

This looks very much like an exception is occurring in sysfer.dll (which is part of 'Symantec Endpoint Protection'

This has been reported as causing problems a few times recently (See [1],[2]). If possible, you should try to update it or create an exception for XWin.exe

I think exception 0x80000001 is STATUS_GUARD_PAGE_VIOLATION. I'm not sure why this doesn't get translated into a non-zero exit code by Cygwin.


Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]