This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

sshd refuses connections since upgrade to 2.4.0-1


Long time Cygwin user but first time error reporter to this mailing list.
Since upgrading my 32-bit Cygwin installation on Win7SP1 x64 from 2.3.1-1 to the current 2.4.0-1 (and also 2.5.0-0.1 in my despair) I can't connect to sshd running as a service anymore.
The service starts and spawns a child in order to handle the connection request, but that fails even when connecting from localhost.
I triaged the problem by trying snapshots between the two releases and traced it to a change after 20151129:
cygwin1-20151129.dll works
cygwin1-20151203.dll fails

The sshd.log remains empty.
In order to create more information to go on I ran strace on the parent (cyg_server spawned) sshd and tried to connect, the strace-log (sshd_cygwin2.4.0_20160109) is attached together with a slightly redacted cygcheck.out

Thanks for looking into this!

P.S. As can be seen from the strace I'm running Agnitum Outpost Firewall Pro and the current EMET - both has never been a problem with Cygwin's sshd (in this installation since May 2010).

Attachment: cygcheck_prs.out
Description: Binary data

Attachment: sshd_cygwin2.4.0_20160109
Description: Binary data

Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]