This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

upgrades hang forever on 0p_000_autorebase.dash


I tried upgrading some old cygwin installs on a couple of computers
today. I downloaded the very latest setup (32 bit) and ran them. On one
machine I ran the upgrade twice, on this machine the process hanged
forever on 0p_000_autorebase.dash

Running 0p_000_autorebase.dash manually from dash I found that the very
first time you run it it works fine, but any subsequent times in
requires user input (and hence would hang forever in a non interactive

It requires user input because the file
is created read only the first time and then the second time a rm
requires user confirmation.

Here is the full terminal output:

$ 0p_000_autorebase.dash
Updating package information in /var/cache/rebase/rebase_pkg.
Updating rebase information for installed dynamic objects in
/bin/rebaselst: 211: /bin/rebaselst: cannot create
/var/cache/rebase/rebase_lst: Permission denied
Updating rebase information for installed executables in
/bin/rebaselst: 197: /bin/rebaselst: cannot create
/var/cache/rebase/rebase_exe: Permission denied
removing /var/cache/rebase/rebase_dyn
rm: remove write-protected regular file '/var/cache/rebase/rebase_dyn'?

As you can see a number of files are created read only and cause a
number of failures.


Patrick Mackinlay                                        tel: +44.7050699851
Yahoo messenger: patrick00_uk                      fax: +44.7050699852
SpaceReg Limited                    

Attachment: signature.asc
Description: OpenPGP digital signature

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]