This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Cygwin unable to resolve hostnames

I don't think it's a "generic Cygwin problem" either. If it was, the
mailing list would be flooded with people having problems with every
net based utility in existence :-)

I think it has to do with how Cygwin interfaces with VMs. Perhaps it
has something to do with network tunnelling or something related to
how ip and DNS works when being NAT'ed through VMWare Fusion.

I am running the Windows 8 VM on VMWare Fusion on OS X 10.11.3

Carl-Erik Kopseng

2016-02-12 10:06 GMT+01:00 Corinna Vinschen <>:
> On Feb 11 11:58, Carl-Erik Kopseng wrote:
>> I disabled IPv6. No change.
>> I pinged my gateway. Went fine, but still ssh fails.
>> I tried creating a /etc/resolv.conf with the same contents as the one
>> on my mac. Same difference.
>> And of course I have tried rebooting my VM. No change.
>> I still get
>> ssh: Could not resolve hostname Non-recoverable
>> failure in name resolution
> I don't think this is a generic Cygwin problem.  I can resolve the
> hostname just fine:
>   $ uname -svr
>   CYGWIN_NT-10.0 2.4.1(0.293/5/3) 2016-01-24 11:26
>   $ ssh
>   The authenticity of host ' (' can't be established.
>   RSA key fingerprint is SHA256:ddcghrb6BI6+TVDKDE3Yf+U43v9EL6u7HsNw7Hec+y8.
>   Are you sure you want to continue connecting (yes/no)? no
>   Host key verification failed.
> Corinna
> --
> Corinna Vinschen                  Please, send mails regarding Cygwin to
> Cygwin Maintainer                 cygwin AT cygwin DOT com
> Red Hat

Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]