This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: subversion 1.9.3-1 segfault

Greg Chicares wrote:
On 2016-02-13 18:41, David Rothenberger wrote:
On 2/9/2016 9:39 AM, Greg Chicares wrote:
'svn' segfaulted on a routine command:

/lmi/mirror/lmi[0]$svn status --show-updates

svn: E170013: Unable to connect to a repository at URL ''
svn: E000104: Error running context: Connection reset by peer
svn update
Updating '.':
zsh: segmentation fault (core dumped)

The command worked as expected when I reran it (after 'svn cleanup'):

It's working now, and I can't reproduce the problem, but I thought
I should report it anyway. I've attached cygcheck -s -v -r output
and copied 'svn.exe.stackdump' below.

Exception: STATUS_ACCESS_VIOLATION at eip=00000000
eax=200C61B8 ebx=200A8DE8 ecx=0022C39C edx=00000000 esi=00000000 edi=00000011
ebp=200C01A0 esp=0022C35C program=C:\cygwin-lmi\bin\svn.exe, pid 1736, thread main
cs=001B ds=0023 es=0023 fs=003B gs=0000 ss=0023
Stack trace:
Frame     Function  Args
200C01A0  00000000 (00000000, 00000000, 6C1D5580, 200A0E90)
200A8DE8  00000000 (00000002, 200A8DE8, 2009EDC0, 200AAEC8)
2009F5D8  00000000 (6C701180, 6C701160, 00000000, 2009F978)
2009EDC0  2009F628 (00000000, 20052794, 200AAF00, 00000000)
20052790  200C81B8 (2004D788, 200430F4, 00000000, 20052C08)
200430F0  2009EDC0 (2003EF00, 20038D6C, 20054CB0, 00000000)
20038D68  20052790 (00000000, 00000000, 20038E88, 00000000)

I wasn't able to get any useful information out of the stack trace.
Running addr2line does not show any functions. I'm not sure if this is
because you don't have the subversion-debuginfo package installed. I
would suggest you install this in case it makes a difference and the
failure happens again.

I've installed 'subversion-debuginfo' and rebooted. After working okay
for a few days, 'svn' is now segfaulting again. A coworker who did a
brand-new Cygwin installation on a new machine yesterday reports 'svn'
failing for her too, also with a stackdump.

Here's my failing command:

/lmi/mirror/lmi[1]$svn update

Updating '.':

zsh: segmentation fault (core dumped)  svn update

(The last line means that 'zsh' caught the segfault, not that zsh crashed.)

Today's stackdump looks much the same to me as last week's:

Exception: STATUS_ACCESS_VIOLATION at eip=00000000
eax=200C6268 ebx=200A8E98 ecx=0022C39C edx=00000000 esi=00000000 edi=00000011
ebp=200C0250 esp=0022C35C program=C:\cygwin-lmi\bin\svn.exe, pid 1164, thread main
cs=001B ds=0023 es=0023 fs=003B gs=0000 ss=0023
Stack trace:
Frame     Function  Args
200C0250  00000000 (00000000, 00000000, 6C1D5580, 200A0F40)
200A8E98  00000000 (00000002, 200A8E98, 2009EE70, 200AAF78)
2009F688  00000000 (6C701180, 6C701160, 00000000, 2009FA28)
2009EE70  2009F6D8 (00000000, 20052794, 200AAFB0, 00000000)
20052790  200C8268 (2004D788, 200430F4, 00000000, 20052C08)
200430F0  2009EE70 (2003EF00, 20038D6C, 20054CB0, 00000000)
20038D68  20052790 (00000000, 00000000, 20038E88, 00000000)
End of stack trace

...and I don't see any useful information from 'addr2line':

$addr2line -e /usr/bin/svn 0x200c0250 0x2009ee70 0x2009f6d8




Attached is fresh 'cygcheck' output.

I'll try running 'svn' under 'gdb'. Is there anything else I can do to help?

That's the only other thing I can think of. If you can catch the segfault and get a backtrace, I may be able to track it down. Or if you can create a simple test case to reproduce the problem, I can use gdb. Honestly, though, it's been a long time since I've done C programming and used gdb in earnest, so it will be slow going for me to debug this.

David Rothenberger  ----

Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]