This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

XWin won't run xterm on start

Dear all: How to make xterm start automatically on XWin start? When I run XWin from a Windows shortcut, the X Server starts, but not an xterm. The same happens when I run startxwin from a cygwin terminal.
(After the X server starts, choosing xterm from the graphical menu does bring up an xterm window. So, xterm is functional.)

The Cygwin/X FAQ is not helpful: there is no CYGWIN environment variable on my system and there is no particular error message. (The system is completely updated as of today. Due to strong filtering of the mailing list, the output of cygcheck cannot be attached in my case; it can be sent it to a private e-mail address if asked.)

Any help? Thanks in advance,


PS. Below is the output of startxwin from a cygwin text terminal:

Welcome to the XWin X Server
Vendor: The Cygwin/X Project
OS: CYGWIN_NT-6.3 dell_vostro 2.4.1(0.293/5/3) 2016-01-24 11:26 x86_64
OS: Windows 8.1  [Windows NT 6.3 build 9600] (Win64)
Package: version 1.18.1-1 built 2016-02-18

XWin was started with the following command line:

/usr/bin/XWin :0 -multiwindow -auth /home/admin/.serverauth.7368

(II) xorg.conf is not supported
(II) See for more information
LoadPreferences: /home/admin/.XWinrc not found
LoadPreferences: Loading /etc/X11/system.XWinrc
LoadPreferences: Done parsing the configuration file...
winDetectSupportedEngines - DirectDraw4 installed, allowing ShadowDDNL
winDetectSupportedEngines - Returning, supported engines 00000005
winSetEngine - Multi Window or Rootless => ShadowGDI
winScreenInit - Using Windows display depth of 32 bits per pixel
winAllocateFBShadowGDI - Creating DIB with width: 3520 height: 1080 depth: 32
winFinishScreenInitFB - Masks: 00ff0000 0000ff00 000000ff
winInitVisualsShadowGDI - Masks 00ff0000 0000ff00 000000ff BPRGB 8 d 24 bpp 32
MIT-SHM extension disabled due to lack of kernel support
XFree86-Bigfont extension local-client optimization disabled due to lack of shared memory support in the kernel
glWinSelectGLimplementation: Loaded 'cygnativeGLthunk.dll'
(II) AIGLX: Testing pixelFormatIndex 1
GL_VERSION:     3.1.0 - Build
GL_VENDOR:      Intel
GL_RENDERER:    Intel(R) HD Graphics 3000
(II) AIGLX: enabled GLX_SGI_make_current_read
(II) AIGLX: enabled GLX_MESA_copy_sub_buffer
(II) AIGLX: enabled GLX_SGI_swap_control and GLX_MESA_swap_control
(II) AIGLX: enabled GLX_SGIX_pbuffer
(II) AIGLX: enabled GLX_ARB_multisample and GLX_SGIS_multisample
(II) 60 pixel formats reported by wglGetPixelFormatAttribivARB
(II) AIGLX: Set GLX version to 1.4
(II) 15 fbConfigs
(II) ignored pixel formats: 0 not OpenGL, 6 RBGA float, 3 RGBA unsigned float, 0 unknown pixel type, 36 unaccelerated
(II) GLX: Initialized Win32 native WGL GL provider for screen 0
winPointerWarpCursor - Discarding first warp: 1760 540
(--) 3 mouse buttons found
(--) Setting autorepeat to delay=500, rate=31
(--) Windows keyboard layout: "00000407" (00000407) "German", type 4
(--) Found matching XKB configuration "German (Germany)"
(--) Model = "pc105" Layout = "de" Variant = "none" Options = "none"
Rules = "base" Model = "pc105" Layout = "de" Variant = "none" Options = "none"
winInitMultiWindowWM - DISPLAY=:0.0
winMultiWindowXMsgProc - DISPLAY=:0.0
winInitMultiWindowWM - xcb_connect () returned and successfully opened the display.
winProcEstablishConnection - winInitClipboard returned.
winClipboardThreadProc - DISPLAY=:0.0
OS maintains clipboard viewer chain: yes
winMultiWindowXMsgProc - xcb_connect() returned and successfully opened the display.
winClipboardProc - XOpenDisplay () returned and successfully opened the display.
Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]