This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: bash completion after equals sign does not work after upgrading to bash_completion 2.1-2

On 2/24/2016 3:41 AM, Imsieke, Gerrit, le-tex wrote:
It still works with bash_completion 1.3-1

COMP_WORDBREAKS is the default â "'><=;|&(:â (the string within ââ).

Removing everything in /etc/bash_completion.d did not help

Compared to bash_completion 1.3-1, there is almost nothing in
/etc/bash_completion.d anyway, and there is no /etc/bash_completion file
any more.

Right. bash-completion now uses /usr/share/bash-completion, as you can see from

Moving away my .bashrc (that contains only 'complete -o default make'
wrt completion and that is symlinked to .bash_profile for some arcane
reason) didnât help, either.

The only thing that worked so far (except reverting to bash_completion
1.3-1) is to use bash --norc.

That's a pretty clear indication that the problem is caused by something in your bash startup files. And the symlink you mentioned could easily be confusing the issue. Have you tried reverting to the default startup files (in /etc/defaults/etc/skel)?

[Achim, /etc/defaults/etc/skel/.bashrc has some outdated comments referring to /etc/bash_completion.]


Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]