This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: passwd -R?

I do have cygserver running as "Local System".

My original issue is that cron stopped working after domain user
password reset. Stopped as - it worked fine before.

My first stop was to reset password with "passwd -R", but it did not
fix my cron problem - not running as user (member of local
Administrators group - getting error in Event Viewer), not elevated
("As Administrator").

I suspect some security policies were modified (machine is part of
domain), but I don't know what to check.

Thanks for weighing in.

On Thu, Mar 10, 2016 at 7:11 PM, Erik Soderquist
<> wrote:
> On Thu, Mar 10, 2016 at 6:22 PM, Andrey Repin <> wrote:
>> Greetings, Alex P!
>>> How do I check that "passwd -R" worked correctly?
>>> I get error messages in Event Viewer when I run it as user (vs "As
>>> Administrator").
>> You must use it with elevated privileges. Else it wouldn't work at all.
> From
> "If normal, non-admin users should be allowed to enter their passwords
> using passwd -R, it's required to run cygserver as a service under the
> LocalSystem account before running passwd -R. This only affects
> storing passwords. Using passwords in privileged processes does not
> require cygserver to run."
> So without the cygserver running, 'passwd -R' is expected to fail
> unless it is running in a privileged shell; if you want it to work
> without a privileged shell, you have to have the cygserver running as
> a service under the LocalSystem account.
> -- Erik

Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]