This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Cygwin/X windowed single window mode not working properly on Windows 10

Thank you Jon.
With the '-engine 1' option it works ok.
My graphics drivers are up to date, so I have no clue what causes this behavior.

On 4/20/16, Jon Turney <> wrote:
> On 19/04/2016 10:13, Yos T wrote:
>> Recently I upgraded from Win8 to Win10. I used to run Cygwin/X with a
>> window manager (dwm) without any problems.
>> After the upgrade this did not work properly anymore. I can still run
>> the X server and dwm starts as expected. However the window does not
>> seem to be refreshing/ repainting correctly. Nothing appears when I
>> start an xterm and type something. When I move the mouse around and
>> click a bit, parts of the screen update and I see the xterm and the
>> commands I typed.
>> I tried a different window manger and no window manager, but just an
>> xterm, all with the same behavior.
>> When I run xterm in multiwindow mode it works as expected.
>> When I run in fullscreen mode (single window) everything also works as
>> expected.
>> I tried the Cygwin 64 bit version, it works in the same way.
>> Any ideas what could cause this?
> This is pretty odd.
> You might try looking for updates for your display driver.
> Failing that, do things work correctly if you add the '-engine 1'
> Xserver option?

Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]