This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: xfig 3.2.5c crashes on Cygwin/X - same problem

On 05/05/2016 02:16, Hara Kiri wrote:
Hello Marco,

last September you were reported xfig 3.2.5c crashing on Cygwin/X when
saving/opening files.

As the same Problem occured to me and there were no followups to the
question or your reply,
I'd like to start a new approach (it doesn't seem to be a widespread
Hope you got the time to look into this.
(I didn't reply on the page so I could attach the cygcheck.out)

What did I do?
1. approach: start Cygwin64 Terminal -> startx -> xfig (in cygwin/X window)
2. approach: start xwin server -> open XTerm (via x applications menu)
 -> xfig

Same result:
xfig works fine, as long as I don't try to open or save files (or
export, even exit).
When I do, the same problem occurs as for the first person.
  xfig3.2.5c: SIGSEGV signal trapped
  xfig: attempting to save figure
(With the extra message: "xfig: <number> object(s) saved in
"/home/<name>/SAVE.fig"" if I drew
objects in xfig. The file does, in fact, exist, but I can't convert it.)

Hopefully this helps you helping me. Thank you in advance.

Best regards,

Please use the cygwin mailing list.
Followup there.

Have you tried Jon's workaround ?


Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]