This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

system lags and dysfunctional after cygwin update

I have been ksh scripting using cygwin for many years over multiple Windows versions (currently 7 and 10) without any issues. I have been using the same version of ksh for a while and in an attempt to compile a more recent version did an update of cygwin whilst I was getting bison which has had some severe side effects on my system. This started about a month ago and I haven't been able to work out a solution by googling or messing around with the installation. It doesn't happen right away but is triggered at some point in a script. One result is that everything takes many times longer to complete. E.g. "ls" goes from under a second to give a listing to 20 or more seconds. One of my scripts that I run daily to produce reports which would take 6 minutes can take up to 3 hours to complete. Another thing that happens is that Internet Explorer stops working - it loads unresponsive and then crashes. Chrome loads but won't reach any website. Firefox works but will become unresponsive frequently. Rebooting fixes the issue until I do something in one of my scripts that triggers it again.

During the update that triggered this, it got stuck in the final part dealing with the 0p_000_autorebase.dash script. I eventually went in to run it manually (line by line at the command prompt). It succeeded in running but did not help unfortunately. I eventually tried removing cygwin from my system and installing it again but it did not help. I have started moving towards manually pasting things into the command line rather than work through scripts as they are more likely to trigger the situation. This usually does the trick to cause the issue (this is a part of my script for generating a bunch of reports):

for client in $clientlist; do
if [[ -s $client.ldap && -n $(awk '{ if (tolower($1) == "username") print "OK"; exit }' $client.rts) ]]; then join -i -j1 -v1 <(awk 'NR > 2 {if ($1=="") exit; print}' ${client}.rts | LANG=en_EN sort -uf) \ <(awk -F'","|"$' '$0 ~ /aaaUUID=/ {print $2}' ${client}.ldap | LANG=en_EN sort -uf) > ${client}.txt &

I noticed when I ran 0p_000_autorebase.dash manually one time that it took a long time to complete. I could see it running slowly as it logged what it was doing on the screen and I let it run all day. When I came in the next day it was either still going or had frozen - I didn't wait to find out and stopped it and rebooted my system. At some point I installed babun which didn't help though at some point mutt stopped being able to send mail in cygwin but continued to work through babun (/usr/sbin/sendmail would give a memory fault but not in the babun installation).

I ran "cygcheck -s -v -r" and have attached the results (I replaced my organization's name with aaa and similar though it probably wasn't necessary). If anyone could offer some advise or help me out it would be greatly appreciated.


Attachment: cygcheck.out
Description: Text document

Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]