This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: system lags and dysfunctional after cygwin update

On 12/05/2016 16:56, Ben Altman wrote:
On 5/12/2016 10:44 AM, Marco Atzeri wrote:
On 12/05/2016 16:35, Ben Altman wrote:

 Another thing that happens is that
Internet Explorer stops working - it loads unresponsive and then
crashes. Chrome loads but won't reach any website. Firefox works but
will become unresponsive frequently. Rebooting fixes the issue until I
do something in one of my scripts that triggers it again.

These can not be an effect of cygwin.
Something else cripped your system.

That is the puzzling thing. It only happens when I am running cygwin or
babun and I can trigger it anytime just by doing ordinary scripting
things. I can easily reproduce the situation though I obviously try to
avoid that. The report script used to run twice daily during the day but
because it now runs for up to 3 hours and causes the situation at the
point where the joins are done I now run it at night so I can reboot my
system first thing in the morning. If I run it during the day I would
have to work with a slow system even after it completed so would need to
reboot. I now have it set to run at night so I can reboot first thing in
the morning.

Before getting up to the joins, I grab data off an ldap server and use
sqlcmd to get data from a sql server. I am getting data for 14 databases
and I do it concurrently and it appears to work fine. When it reaches
the joins, suddenly everything slows and becomes unstable. Another
script I have which I use to search flat files also runs in to a similar
situation though it doesn't use "join" and I haven't worked out which
line triggers it.


the cygcheck is from a Babun 32 bit installation on a 64 bit machine.
The DLL is also not recent

  Cygwin DLL version info:
        DLL version: 1.7.35

Any chance to install a minimal 64bit Cygwin to see if the problem
is still there ?


Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]