This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: changes in 32-bit Cygwin OpenGL causing crashes?
OpenGL and drivers are not on the supported list.

I suppose cygwin problems will all be moot once the
Windows 10+Canonical Ubuntu is well-established, but we're not there yet.

Lloyd Wood

----- Original Message -----
From: Andrey Repin <>
Sent: Wednesday, 25 May 2016, 16:39
Subject: Re: changes in 32-bit Cygwin OpenGL causing crashes?


>> It seems still the same problem with dri-drivers 
>> probably caused by LLVM 3.7

> Unfortunately, the dri-driver versions available in the installer
> depend on LLVM 3.7, so, even though reverting back to LLVM 3.5
> is offered when you select llvm, you can't pull in a dri-driver
> that works with that older version of LLVM to test that hypothesis.
> So, not much point to offering that older version of LLVM.

> Regardless of the fact that OpenGL is broken (again), this is
> really a problem with Cygwin as a perennial work-in-progress
> and its (lack of) version control.

> I'd like to be able to download a stable-known-to-work-on
> a-specified date golden-master Cygwin, without incremental
> upgrades, and revert to that known-to-work Cygwin if needs
> be. Once every six months? I'd be good with that.

RedHat offers paid support for Cygwin, you know.

And it would be really wonderful, if you teach your mail client to not break

With best regards,
Andrey Repin
Wednesday, May 25, 2016 09:38:43

Sorry for my terrible english...

Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]