This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Extreme Slowness of cygwin commands [SOLVED?]

On 5/26/2016 6:03 PM, bzs@THEWORLD.COM wrote:
(Windows 7 pro, laptop, SSD, 2.5.1(0.297/5/3))

A few weeks ago I reported extreme slowness in cygwin process
activation after a fresh install. For example something relatively
simple like 'ls' or even 'pwd' would take 15+ seconds to start.

There was no other significant activity on the system and commands
from a command shell or windows power shell started with normal speed.

It just happened again.

Rapport Trusteer Endpoint Protection was running.

It's an IBM product and various banks are beginning to require this is
running before they will let you log in to your account. Typically if
you're not running it when you try to login you'll be stopped with a
"download and install (Trusteer) now" pop-up from the bank site, it's
not something you buy or similar.

I found and clicked their Stop Trusteer Endpoint Protection via the
Start menu.

For some reason beyond my comprehension they require you enter a
captcha but ok no big deal. A popup telling you they are stopping it
lingers for a couple of minutes.

When that popup disappears I went into Task Manager as Administrator,
located Rapport Management Service (something close to that, only
Rapport thing running) and did a right-click end-process.

Slowness immediately disappeared.

I can't say for certain it's related, maybe some other process let go
of something while I was fiddling, but this is the second time this
has worked.

Perhaps someone with more time than I have can try installing
Trusteer, I believe anyone can get it here:

and reproduce this: Slowing down cygwin a lot while not interfering
with other windows activities and perhaps figure out why.

Unfortunately the interference seems intermittant. It was running for
at least a week before this incident and I hadn't noticed any slowdown
until just now. I do type into a cygwin window probably a few times
per hour when working.

Perhaps someone at IBM could take an interest but likely they'd want
more analysis.

At any rate that's the workaround: Stop Trusteer, see if it helps.

I also have Rapport Trusteer installed from BoA with Firefox and have not had the problem when using it. On the other hand in my case I may have discovered a connection with Softerra laimex command line utility. A script which uses it on a desktop has the slowness issue whenever the script is run (after sqlcmd and laimex has completed, the issues surface for the rest of the script). I was unable to set up my script on a laptop in part due to the need of the use of a VPN and because the IP addresses I was given were not "private" (for unknown reasons as it should have worked either way just like on my desktop that had the slowness issue). Once I replaced all of them with the "private" one's I was given, laimex worked to get the data I needed. A week later (today), I check the PC that was giving me problems and it was running smoothly without the issue happening and this coincided with me updating my config file with the updated IP addresses. There are still some puzzling things, like why this all started after an update to Cygwin. What I need to do now is to set up a test config file with the old addresses and see if I am forced to reboot the desktop due to the slowness. The thing is that when running Softerra LDAP Administrator and getting data through the GUI, it was never an issue.


Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]