This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Problem with git on cygwin64 on Windows 10 (2.8.3-1)

Thomas Nilsson skrev:
Suddenly git is acting up on me. I have a number of local repos from
various sources (GitHub, bitbucket, ...) and since a day or two I can't
push or pull from any of them. Can't even clone fresh repositories.

Mostly I get 'fatal: unpack-objects failed', but also 'index-pack
failed'. And sometimes just nothing, like an abort without any output, e.g.

 > Thomas@thoni64 ~
 > $ git clone
 > Klonar till "cgreen"...
 > Thomas@thoni64 ~
 > $

I've tried running in administrator mode but no difference. I can
successfully clone the repos from Linux and Darwin so I'm pretty certain
the problem lies in cygwin git (or something else cygwin... or windows...)

My cygwin git is 2.8.3-1 but reverting to 2.8.2-1 did not help.
Everything else is up-to-date, windows is Version 1511 10586.420.

Has anyone seen this before? Any pointers? Removing and reinstalling

Any pointers appreciated!


Running with a shortened environment, as in "PATH=/usr/bin git..." did not help.

I've also done a rebase-all. (And rebooted windows of course...)

Running git under gdb indicates broken pipes or SIGSEGV. The last case provides the following info if that is of any use:

> Program received signal SIGSEGV, Segmentation fault.
> [Switching to Thread 11400.0x294c]
> 0x00007ffbd6449fd1 in KERNELBASE!GetOverlappedResult ()
>   from /cygdrive/c/WINDOWS/system32/KERNELBASE.dll

I've attached a cygcheck output.

Thanks for any help you can provide.


Attachment: cygcheck.out
Description: Text document

Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]