This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

issues with startxwin not loading x windows

I recently switched from a windows 7 laptop to windows 10 at work here; I had cygwin 64 working with metacity as my preferred frontend for x windows with no problems.  Inexplicably on the 16th it ceased functioning.  I attempted a reinstall and instead, now I get is a black popup momentarily, then nothing happens.  Enclosed are various log files/etc.

I cannot unfortunately give my cygcheck.out without giving away a lot of internal corporate information so that was redacted since it's absolutely necessary.  That said, all of the various packages said 'ok' for them.  I've had my trend micro office scan administrator add my pc's C:\cygwin64 folder to the exceptions section of the configuration.   Also scanned the hard drive/FS for filesystem on windows; nothing found.

I cannot boot into safe mode because of bitlocker.

So enclosed is my redacted cygcheck.out; my xsessions.error file from 8/16, my xwin.0 file, and a copy of the gdb output.

Interestingly when I try to do a strace on it, I just get 'segmentation fault' as the output.  Output log file is empty.

I'm baffled here and being mostly pure linux, I kind of live and die by my cygwin instance.  
Any thoughts here?  Please note neither opening the terminal and typing any variation of startxwin, xwin, startx, or using any start menu icons for x windows will produce anything but the described result of nothing happening Though at least from a terminal window I get some output before it refuses to start like this:

$ startxwin

Welcome to the XWin X Server
Vendor: The Cygwin/X Project
OS: CYGWIN_NT-10.0 LTFA25932 2.5.2(0.297/5/3) 2016-06-23 14:29 x86_64
OS: Windows 10  [Windows NT 10.0 build 10586] (Win64)
Package: version 1.18.4-1 built 2016-07-22

XWin was started with the following command line:

/usr/bin/XWin :0 -multiwindow -auth

(II) xorg.conf is not supported
(II) See for more information
LoadPreferences: /home/050162/.XWinrc not found
LoadPreferences: Loading /etc/X11/system.XWinrc
LoadPreferences: Done parsing the configuration file...
winDetectSupportedEngines - RemoteSession: no
winDetectSupportedEngines - DirectDraw4 installed, allowing ShadowDDNL
winDetectSupportedEngines - Returning, supported engines 00000005
xinit: giving up
xinit: unable to connect to X server: Connection refused
xinit: server error

Attachment: XWin.0.log
Description: XWin.0.log

Attachment: gdbout.txt
Description: gdbout.txt

Attachment: ATT07347.xsession-errors
Description: ATT07347.xsession-errors

Attachment: cygcheck.out
Description: cygcheck.out

Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]