This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: getting cancelsynchronous IO error when starting mintty.exe from Windows XP desktop shortcut

Hi, Prabhakar,

I upgraded my cygwin in XP to 2.6 and found that it doesn't work, so I
opened the last 32bit installer again and in the "Select packages" section
clicked the <View> button to change to full list view, and then searched 
for "cygwin" (without the quotes). The list showed three packages with the
2.6.0 version. I clicked in the version number to change it to 2.5.2 (in
"cygwin" and "cygwin-devel") and 2.5.0 (in "cygwin-doc"), then clicked on
<Next> to continue the installation.

The installer downgraded the libraries. The shell terminal and cron, sshd 
services worked again!

I have not tested this in a new installation, as this is the only XP system
keep in operation to run some 16bit apps, the rest being win7/8.1s, but I 
hope you can do the same to downgrade your cygwin. 

Of course, when we have to upgrade packages again in the future, we must 
confirm that these three packages are marked "keep" to avoid them to be 
modified by the installer during the upgrading process.


View this message in context:
Sent from the Cygwin list mailing list archive at

Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]