This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

can't run cygwin emacs or XWin Server

I run 32 bit cygwin on a 64 bit machine running Windows 7.

I used to get an XWin Server terminal running bash at startup (logging into Windows) from which I could run the emacs packaged in cygwin. After a round of updates I don't get the terminal window at startup and if I try to manually launch it it fails to launch and AFAICT if I try to run emacs from a command prompt I get the native version of emacs that I also have installed and not the cygwin one. The shortcut for XWin Server is

   C:\cygwin\bin\run.exe /usr/bin/bash.exe -l -c /usr/bin/startxwin.exe

This seems to me to be the "phantom /usr/bin issue" mentioned at because I get the same behaviour described there and in related posts. I have verified that "/usr/bin" and "/bin" are the same as far as ls is concerned. The relevant part of the path as shown in System Properties > Advanced > Environment Variables is "C:\cygwin\usr\bin;C:\cygwin\bin" which precedes "C:\Users\Mike\Downloads\emacs-25.1-2-i686-w64-mingw32\bin" in the path which is what ends up running.

However if I run the MS shell in emacs or use command prompt then "which ls", "which bash", "which emacs", "which printenv", "which startxwin" and "which which" all come back with "/usr/bin/..." so those are recognised by which at least.

I hope I'm just missing the obvious.  Thanks for any help

Merry Christmas

Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]