This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Hangs on connect to UNIX socket being listened on in the same process (was: Cygwin hanging in pselect)

On Jan  9 16:46, Erik Bray wrote:
> Hi Corinna,
> Thanks for the response.
> On Mon, Jan 9, 2017 at 3:13 PM, Corinna Vinschen wrote:
> > Right.  It has to do with how connect/accept works on AF_LOCAL sockets.
> > The handshake doesn't work well for situations like yours, where the
> > same thread tries to connect and accept on the same socket.
> Actually I'm not entirely sure now that that's the issue, even
> considering that this has come up before.  Or at the very least,
> there's an additional issue.  I realized that when I tried separate
> client/server processes, in the server I had put an accept() call at
> the end so it would block there.  With the server waiting to accept a
> connection it succeeded.  However, when I replaced the accept() with a
> long sleep(), the client's connect() never returns.

That's because connect infinitely waits for the accept to reply the
second half of the handshake.

> IIUC the handshake can't succeed until and unless the server accepts a
> connection from the client.

This is exactly the underlying problem.  And interesting enough, even
though the handshake is in Cygwin since 2001, we never had a problem
with this until Christian started porting postfix in 2014!

> I almost wonder if the server side in this case
> shouldn't start up a thread to accept the af_local handshake, but you
> would know better.

No, I don't.  We discussed this issue briefly back in 2014, but as
you can see we don't have a solution for this border case yet.

Starting a thread may or may not work, but there are a couple of
use-cases to keep in mind (which I can't reproduce off the top of my head).
The old postfix cygwin-apps thread from 2014 might give you some idea.

> > This has been found a problem in porting postfix already and at the time
> > we added a patch to circumvent the problem.  Before calling connect, add
> > this:
> >
> >   setsockopt (sock_server, SOL_SOCKET, SO_PEERCRED, NULL, 0);
> >   setsockopt (sock_client, SOL_SOCKET, SO_PEERCRED, NULL, 0);
> >
> > This is, of course, a hack.  The problem here is that server and client
> > of a socket are independent of each other, and there's typically no
> > way to know which process created the server side unless you already
> > are connected.  Chicken/egg.
> I tried it and it worked, both in the single process and separate
> process examples.  I see now--this sets
> fhandler_socket::no_getpeerid=true, so it doesn't have to do the
> handshake at all.

Right.  A better solution for the problem would be nice.  Ultimately
we want to check if the other side of the socket is actually a Cygwin
process which knows the secret, not a stray native Windows process
which accidentally hopped on the bandwagon, and we want to exchange
the credentials so a subsequent SO_PEERCRED call returns correct values.


Corinna Vinschen                  Please, send mails regarding Cygwin to
Cygwin Maintainer                 cygwin AT cygwin DOT com
Red Hat

Attachment: signature.asc
Description: PGP signature

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]