This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Stuck with incomplete Cygwin installation

Quick summary: I'm stuck being unable to achieve a working Cygwin
installation on a machine that formerly had one.

I recently tried to update Cygwin packages using setup, and developed
the "bash: fork: retry: Resource temporarily unavailable" issue which
many online posts indicate  can be cured with a "rebaseall" procedure.
That procedure didn't work for me, so I've uninstalled/reinstalled
Cygwin multiple times, and  can't achieve a complete  Cygwin
installation. I now face the following issues after running setup:
* As part of the postinstall routine operated by the setup program,
the and postinstall scripts
both exit abnormally (error code 254 for each).
* While /home is generated by setup, a home directory for me within
/home does not get created.
* /etc/skel also does not get created.
* Upon accessing a bash shell environment by opening a Cygwin terminal
(mintty) using the desktop shortcut created by the setup program, I
see the PATH variable does not include any directory within the Cygwin
installation. Specifically, my Cygwin installation is rooted at
C:\cygwin64 and  PATH does not include any directory rooted at
/cygdrive/c/cygwin64 (such as /cygdrive/c/cygwin64/bin).

I''ve tried the following multiple times to address these issues, with
the same unsuccessful outcomes as described above:
* Removed Cygwin per (I've saved
my home directory from the last successful Cygwin installation, but
haven't copied any files from it to the new installations.) Note: At
least since attempting reinstallation, if I close all Cygwin terminal
windows, I do not see any Cygwin-related processes running in the
Windows Task Manager.
* Reinstalled Cygwin as administrator, as well as tried using setup's
--noadmin and --disable-buggy-antivirus command-line options.
* Used different Cygwin download sites (selected within the setup
program). I didn't expect this would help, but tried anyway.
* Installed only default packages (and the packages they depend on).
* Speculating it might help, I tried installing the cygrunsrv package
despite setup indicating it's not needed by default. Indeed, this
approach didn't help. Further: While cygrunsrv files do get installed
on the disk (e.g. /usr/sbin/cygserver.exs exists) there's no evidence
a related service is being installed in a way Windows
recognizes--there's nothing Cygwin-related listed by Windows'
application for managing services, services.msc.
* '/usr/bin/rebaseall -v' -- the  command appears to run successfully,
but re-running setup afterward does not address the issues noted
above, and the two postinstall scripts fail again when setup runs
* '/usr/bin/rebase-trigger full' -- same effect, upon running setup,
as described in previous line.
* Used Windows facility to delete read-only permission on my
installation directory (C:\cygwin64) and for subdirectories nested
within it...and re-ran setup afterward.
* Attempted to manually run the and postinstall scripts from the command line. These
attempts always yield errors of the following kind (the numbers, other
than "errno 11", vary):
--- begin typical error message ---
1152878 [main] sh 304 fork: child 27120 - died waiting for dll loading, errno 11
./ fork: retry: Resource temporarily unavailable
--- end typical error message ---
Additionally, running setup after attempting to run these scripts
manually causes not only the scripts to again fail when invoked by
setup.exe, but the 0p_000_autorebase.dash script also fails, with exit
code 2.
* Re-downloaded the setup program.

Some more details:
* Windows 10 machine
* Cygwin setup.exe version 2.877 (64 bit)
* I've attached /var/log/setup.log.full from my most recent
installation attempt, in case it might help.
* I have extensive but somewhat limited administrator rights on this
Windows machine; in particular, I can't suspend or disable the
anti-virus software. However, I've never before had a related problem
with Cygwin--not on this machine I've had since August 2016, and not
on any other machine with same limited admin rights I've had over the
past 7+ years. This all strongly suggests to me (IMHO) the anti-virus
software, and my limited admin rights, are not interfering with the
Cygwin installation.

After hours of searching the web and attempting multiple
reinstallations, I'm sorry to lean on the community for help, but I'm
really at wits end. I'm willing to try new ideas, and appreciate any

Thanks very much in advance,

Attachment: setup.log.full
Description: Binary data

Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]