This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Another BLODA with Cylance PROTECT? Can't rebase

On Fri, 21 Apr 2017, Corinna Vinschen <> wrote:
On Apr 19 14:25, Timothy McDaniel wrote:
$ ./0p_000_autorebase.dash
creating empty /var/cache/rebase/rebase_pkg
      0 [main] dash 12952 fork: child 12912 - died waiting for dll
loading, errno 11
/bin/rebaselst: 98: /bin/rebaselst: Cannot fork
$ ./
      0 [main] sh 13628 fork: child 10276 - died waiting for dll loading,
errno 11
./ fork: retry: Resource temporarily unavailable

That's pretty bad, considering that ash only links against the Cygwin
DLL itself.

Running /bin/rebaseall by hand, the old way, had no output and no

No effect?  How do you know?

My apologies.  I later ran with the verbose option, letting it choose
an address, and later choosing a few myself.  There was output saying
that it was rebasing each package.  Instead of "no effect", I should
have written that the exact same error message came up when I tried to
run anything slightly complicated.  (Simple commands work, but
harmless-looking things like "time" and many pipes fail.)

If you're sure Cylance PROTECT is the culprit,

I'm not.  It did not throw up any messages or log any events about
blocking anything.  It's just that most BLODA appears to be antivirus
systems, and it's the only substantial change that I know of in my
work systems.  (We're still on the same version of Windows.)

I have a little more information.  A co-worker told me that he uses
"Babun",  It's Cygwin, but with a larger
number of installed and configured packages and a moderately more
convenient control system.  I installed it and it works fine ... but
immeidately on installation, it's an old Cygwin.  (By defualt, each
day it auto-updates to the current Cygwin.)

    Jun 23  2015 libcygwin.a

For example, Perl there is 5.14.4, but the current Cygwin Perl is
5.24.1.  pcre is 8.36, versus current 8.40.3.  But, like I said, it
works.  If I update to the latest, though, it fails in exactly the
same way as a regular Cygwin installation.

So all I can say is that it seems that there was some change to
libcygwin.a some time in the last 2 years to which my system is
allergic for some reason, which is hardly any help.

But I don't know how to proceed further, except by letting this 2015
installation sit and never ever update it.  Or install a virtual
machine with disk sharing and try to do my occasional UNIXy work with
it.  Someone from the local support team has asked why I was asking
about Cygwin, and why I'm interested in "Running OSes on top of
OSes".  So I may have to go the VM route.

Tim McDaniel,

Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]