This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Emacs 25.2.1 Fails to Start Server

On 7/31/2017 7:27 PM, Erik Knowles wrote:
> Apologies for emailing directly -- I forgot to subscribe to the cygwin list so I don't have a list message to reply to. If you wouldn't mind sending your reply to the list (as a reply to my original msg?), I am now subscribed and should be able to reply to future responses through the list.
>> I wouldn't expect this to work, because of the '&'.  Here's what I see
>> when I run that command interactively:
> When starting the server (that is, when the server actually works) adding the "&" gets me my Bash prompt back after the server gets going. Without the "&" the server still started fine; it's just that the Bash prompt was locked until the server exited.
> On to the problem. I notice in your first example that you're using the X-11 version of Emacs. I don't have emacs-X11 installed -- I'm using (and have been for years) the terminal version. Can you try adding "-nw" to see if the terminal version works for you?

I ran it from mintty, not under X11, so -nw wouldn't change anything.

> On your "emacs-w32 --daemon -q" example, can you connect to that server using emacsclient-w32? From your sample it looks like the server hung (from memory, a successful startup is signalled by a message to the effect that a socket is being created).

$ emacs-w32 --daemon -q
Starting Emacs daemon.

$ echo blah > foo

$ emacsclient-w32 -c foo
Waiting for Emacs...

[An emacs-w32 frame opened up, visiting foo.  I exited with C-x #.]

> Re: The multiple cygwin1 dll's, I'm aware of the outdated one. It's at the very end of the search path so it should never be loaded (except for the program in that directory that needs it), but I did go ahead and verify (using Sysinternals' Process Explorer) that the current version is being used.


Are you able to start the server by doing 'M-x server-start' within emacs?


Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]