This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

sshd login gives "unable to load user32.dll, Win32 error 1114"

When I try to log into sshd on one of my hosts as a particular user, I get the

      2 [main] sshd 6444 C:\cygwin64\usr\sbin\sshd.exe: *** fatal error - unable
to load user32.dll, Win32 error 1114

I looked in the archives for this problem and found one discussion[1], which
referenced a FAQ[2] about using sshd in a domain. I don't have a domain, but I
went ahead and followed the instructions there anyway: On the server host I ran
(from an administrative shell)

editrights -u cyg_server -a SeTcbPrivilege
editrights -u cyg_server -a SeCreateTokenPrivilege
editrights -u cyg-server -a SeAssignPrimaryTokenPrivilege

then stopped sshd, reran ssh-host-config, and restarted sshd. I still get the

Two users are allowed to log in to sshd - call them user1 and user2. user1 isn't
a member of the Administrators group, and does have this problem. user2 is a
member of Administrators, and doesn't have this problem.

Can anyone suggest something else to try?



Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]