This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: setup stuck on cygwin.ldif


On 09/10/17 04:16, Brian Inglis wrote:
On 2017-10-08 07:46, Shaddy Baddah wrote:
I have a weird problem happening... so I have tried to update a 64-bit
Cygwin installation on Windows 10 Pro. I closed all Cygwin processes,
and a ps -ef is showing only the ps process itself.
In anycase, during the install I was prompted that the file
/usr/share/cygwin/cygwin.ldif was busy.
I ran Process Explorer and searched for what might have the file open.
I couldn't find anything. I clicked retry a number of times, but it
wouldn't yield. Finally, I clicked continue. And now I'm stuck in this
endless loop on the file:
It's a animated gif, so you may have to select play in your browser. Not
much to see, except the constant attempt to install the cygwin.ldif
Any ideas here? I guess I'll have to kill setup... but I fear that it
will play havoc with my install :-(

Have you tried Windows cmd OPENFILES /Query ?

So I tried to "Reinstall" all, and now the problem has shifted. Every
attempt to reinstall stops with "Unable to extract
/etc/defaults/etc/pki/ca-trust/ca-legacy.conf". "The file is in use or
some other error occurred.".

Retry doesn't help. openfiles doesn't reveal anything:

Having enhanced setup.exe at one point, and accordingly debugged it,
I'll try and see if I can turn up the logging, see what is going on
exactly. I actually don't know where setup.log/setup.log.full is going
to at the moment.


Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]