This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Cygwin alongside WSL

Am 26.10.2017 um 18:13 schrieb Brian Inglis:
On 2017-10-25 15:18, Thomas Wolff wrote:
Am 25.10.2017 um 20:30 schrieb Brian Inglis:
On 2017-10-25 11:27, Brian Inglis wrote:
On 2017-10-25 00:29, Thomas Wolff wrote:
Am 25.10.2017 um 00:19 schrieb Angelo Graziosi:
Thomas Wolff wrote:
Mintty 2.8.0 simplifies WSL integration a lot.
In Cygwin, you can simply start e.g. mintty --WSL=Ubuntu (add -~ to start in
the WSL home).
Does it mean that 2.8.0 does not need wslbridge [*] any more?
No, sorry, I forgot to mention that wslbridge would have to be installed
in /bin to make this work.
As it is not a Cygwin package, I have installed wslbridge in /usr/local/bin/,
which is in the system Path in Windows format, so also in the Cygwin path in
Unix format - will this work?
Would a symlink, winsymlink, or .lnk as /bin/wslbridge to /usr/local/bin/?
Why don't you just try it? Both wslbridge and wslbridge-backend must reside in
/bin, hard links will work of course.
It looks like without the Fall Update --WSL= does not work with either
no/default distribution found, and the same result with a variety of obvious names:


It would be nice if --WSL did the right thing for legacy installs also.
Yes, I am aware of this gap, see
Also for longopts --WSL should allow an optional_argument, ...
I was not aware of this feature of getopt, thanks.

Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]