This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re[2]: Problem running the latest python2-2.7.14-1 under AppVeyor

On Fri, 3 Nov 2017 15:26:27 +0000 Jon Turney <> wrote:

JT> On 03/11/2017 14:45, Vadim Zeitlin wrote:
JT> > Our build has started on AppVeyor, a continuous integration provider,
JT> > started failing since a couple of days as a makefile command running a
JT> > Python script started failing with exit code 127 without any more
JT> > information. This is a strange situation as I can't reproduce the problem
JT> > locally, but something definitely seems to be wrong with this package on
JT> > the AppVeyor machine as Python just doesn't seem to be executable, e.g. the
JT> > output of these commands in our batch file driving the build:
JT> Perhaps you need to provide the -g (--upgrade-also) flag to cygwin's setup.

 Thank you! This has indeed fixed it and Python runs now, after having
updated a whole lot of other packages[*]. And it also explains why I failed
to reproduce it locally: it must have installed all the right versions of
the packages for me, as I hadn't had them before.

 Thanks again for helping with resolving this issue!


Attachment: pgpxZjKTRq0cb.pgp
Description: PGP signature

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]