This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Whither perl-CPAN-Meta-Requirements?

Norton Allen writes:
> I am trying to install a perl module using cpan (target module not
> available via cygwin setup), and the process is failing due to an
> out-of-date CPAN::Meta::Requirements module.

This module (like a few others) is built into Perl core itself and no
newer version is available on CPAN yet.  Hence currently there is only a
dummy module available for Cygwin which ensures that any installations
from older Perl versions get uninstalled (you couldn't use them anyway
since they'd be in the installation for the old Perl).

> Did these get absorbed into some other package? I do see some of the
> files exist in perl_base-5.26.1-1, which I have installed, but that
> apparently does not provide a recent enough version of
> CPAN::Meta::Requirements.

The installed version is exactly what you are asking for:

$ corelist -v 5.026001 CPAN::Meta::Requirements
CPAN::Meta::Requirements 2.140

You probably also need to install the perl package itself if you
haven't, perl_base is there only for satisfying some common dependencies
without incurring the overhead of a full installation.

Running the cpan shell works for me and it's not requesting me to do any
updates either.

> Have I entered version hell by using cpan?

I'm not sure what exactly you did, so I can't comment.  Maybe clean up
your installation, re-install perl and try again?

+<[Q+ Matrix-12 WAVE#46+305 Neuron microQkb Andromeda XTk Blofeld]>+

SD adaptations for Waldorf Q V3.00R3 and Q+ V3.54R2:

Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]