This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: cmake install; required cyglz4-1.dll not installed in /usr/bin or anywhere else;manual install solved problem.

On 2017-12-20 17:08, Vijaya Subramanian wrote:
> Thanks a lot. This worked but only with the new version of setup.exe that is out
> right now.
> On Tuesday, December 19, 2017, 11:22:39 PM MST, Brian Inglis
> <> wrote:
> On 2017-12-19 22:47, Vijaya Subramanian wrote:
>> On 2017-12-19 10:43, Vijaya Subramanian via cygwin wrote:
>>>On Tuesday, December 19, 2017, 11:36:08 AM MST, Brian Inglis wrote:
>>>> I checked /var/log/setup-full.log and found the below instances where
>>>> libz4-1 was mentioned
>>>> package liblz4-devel comparing versions 131-1 and 131-1, result was 0
>>>> package liblz4_1 comparing versions 131-1 and 131-1, result was 0
>>>> package liblz4-devel comparing versions 1.7.5-1 and 131-1, result was -1
>>>> package liblz4_1 comparing versions 1.7.5-1 and 131-1, result was -1
>>>> 2017/12/02 14:06:47 Adding required dependency liblz4_1: Selecting
>>>> already-installed version .
>>>> 2017/12/02 14:06:47 Changing gid back to original
>>>> So I am not sure why I get the following message when I run cmake:
>>>> When I try to run cmake, I get the following error message:
>>>> C:/cygwin64/bin/cmake.exe: error while loading shared libraries: ?:
>>>> cannot open shared object file: No such file or directory
>>>> or why cygcheck cmake says: cygcheck: track_down: could not find cyglz4-1.dll
>>> Cygwin setup currently has problems upgrading when version numbers change
>>> formats and a solution is being addressed by the volunteer maintainers.
>>> You have to manually run Cygwin setup, find the liblz4 packages you have
>>> installed, and select the new version number to be installed 1.7.5-1.
>> Want to confirm setup-x86_64 -D liblz4-1 -q -g is what I input on the
>> command line to upgrade the package? Do I have to install cmake again?
> You can not use setup from the command line to upgrade to a different version
> format: Cygwin currently has no way to specify a package version on the command
> line like apt ... pkg=ver. You will just get the same messages and problems as
> before.
> You must download and run Setup interactively.
> On the Select Packages panel, change View to |Full| or |Up To Date|;
> in Search enter |liblz4|;
> on each package line under column New, click until the version to be installed
> reads 1.7.5-1;
> click the [Clear] button;
> change View to |Pending| to verify the version;
> then click [Next] to upgrade.

It worked when I did it with earlier setup on 2017-09-05.

Take care. Thanks, Brian Inglis, Calgary, Alberta, Canada

Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]