This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Can't connect to ssh host with Emacs tramp


Have you tried to set in your ~/.emacs file ‘tramp-verbose’ variable?
If not, then add to the file the following line:

(setq tramp-verbose 6)

In '*debug tramp/scp remote_host_name*' buffer you'll see all interactions
between tramp, ssh and your remote host.

Good luck!

On Fri, Jan 5, 2018 at 10:37 AM, David Karr <>

> On Thu, Jan 4, 2018 at 5:15 PM, Ken Brown <> wrote:
> > On 1/4/2018 5:42 PM, David Karr wrote:
> >>
> >> I've reviewed some of the Emacs tramp documentation, but I'm not sure
> >> what the issue is.
> >>
> >> If I'm using Cygwin, I don't need the putty components for this, do I?
> >
> >
> > No, I make ssh connections through Emacs tramp without putty.
> >
> >> When I attempt to open a text file in my homedir on a remote host,
> >> which I can ssh to (passwordless) from the shell, it just times out.
> >>
> >> The *Messages* buffer shows this (fqhn is the hostname):
> >> ------------------
> >> Tramp: Opening connection for fqhn using scp...
> >> Tramp: Sending command ‘exec ssh   -o ControlMaster=auto -o
> >> ControlPath='tramp.%C' -o ControlPersist=no -e none fqhn’
> >> Tramp: Waiting for prompts from remote shell...
> >> Timeout reached, see buffer ‘*tramp/scp fqhn*’ for details
> >> Tramp: Waiting for prompts from remote shell...failed
> >> Tramp: Opening connection for fqhn using scp...failed
> >> -----------------------
> >>
> >> There doesn't appear to be a buffer named "*tramp/scp fqhn*".
> >
> >
> > Sorry, I don't know enough about tramp to diagnose this.  Maybe it would
> > help if you would say exactly what commands you gave.  And does the
> problem
> > occur if you start with 'emacs -Q'?
> What "commands" am I giving?  All I'm trying to do is open a single
> file on the remote host.
> I'm entering "//fqhn:/home/<myuid>/.bash_profile".
> I get different behavior using "emacs -Q".  I don't get a timeout
> error, but I also don't think it even attempted to connect to the
> remote box.  The editor view just opens with the given name, but it's
> empty (it shouldn't be).  The "*Messages*" buffer doesn't indicate
> that it ever tried to make a connection.  It also says "Use M-x
> make-directory RET RET to create the directory and its parents".
> The other frustrating issue with my full Emacs configuration is that
> when I enter the second forward slash, key response vastly, and I mean
> vastly, slows down. I've gone through the tramp FAQ looking for
> potential performance issues, but nothing has helped.
> --
> Problem reports:
> FAQ:         
> Documentation:
> Unsubscribe info:

Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]