This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: xhost: unable to open display ""


The solution was stupider than I thought:
1. I thought my DISPLAY was set, but it actually wasn’t. It worked with “:0.0”.
2. “ssh -Y” worked, whereas “ssh -X” did not.

Voila! (so far)

Thanks for your help, guys.

Jim Waltz

Sent from my iPhone

On Jan 23, 2018, at 22:48, Jack <<>> wrote:

On 2018.01.23 19:57, Mark Geisert wrote:
Waltz, James wrote:
I think that I have installed all the necessary packages, but I still get the above error, when I type “xhost +” on my local machine.
I am also still getting a “cannot open display: localhost:10.0” error.
This is DESPITE the fact that:
- I set DISPLAY to “localhost:10.0”
- X11Forwarding is set to “yes” in the sshd_config file
- I changed the “hosts” file, under /etc to have actual IP addresses.
Any idea why this might be happening?
Yes.  Change that "10" to "0".  So it's "localhost:0.0" or even ":0.0".
Should work much better.... :)
Unless ssh is involved, which was not stated, but I suspect might be part of the issue.

Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]