This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: missing file cyggc-1.dll

On 2018-01-27 13:16, U-BLASTER-6000\mtdew wrote:
> I ran into a small problem (for the gurus).
> I ran configure and the make. Make got hung with the following error.
> $ cygcheck /usr/bin/make.exe
> C:\cygwin64\bin\make.exe
>   C:\cygwin64\bin\cygwin1.dll
>     C:\WINDOWS\system32\KERNEL32.dll
>       C:\WINDOWS\system32\ntdll.dll
>       C:\WINDOWS\system32\KERNELBASE.dll
>   C:\cygwin64\bin\cygguile-2.0-22.dll
>     C:\cygwin64\bin\cygcrypt-0.dll
>     C:\cygwin64\bin\cygffi-6.dll
>     C:\cygwin64\bin\cyggmp-10.dll
>     C:\cygwin64\bin\cygiconv-2.dll
>     C:\cygwin64\bin\cygintl-8.dll
>     C:\cygwin64\bin\cygunistring-2.dll
>     C:\cygwin64\bin\cyggcc_s-seh-1.dll
>     C:\cygwin64\bin\cygltdl-7.dll
> cygcheck: track_down: could not find cyggc-1.dll
> It appears that I have this installed in the package libgc-1 and
> libgc-devel. I am not sure why make cannot see this file. Is there a way
> so that I can trick it to find that library file?

Check that /bin/cyggc-1.dll exists, its permissions are a+rx, and chmod those
permissions if not, or reinstall package libgc-devel.

Take care. Thanks, Brian Inglis, Calgary, Alberta, Canada

Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]